SharePoint på ren svenska

Problem med ”Du måste ange ett värde för det här obligatoriska fältet”

Härrom dagen lanserade jag ny branding hos en kund jag tidigare gjort brandingjobb hos, nu innefattade det lite nya färger och ny sidlayout m.m. Men, lanseringsdagen mailar kunden och skriver att de har problem när de ska editera deras wikisidor. Varje gång de ska spara ner dem får de felmeddelandet ”Du måste ange ett värde för det här obligatoriska fältet” eller på engelska ”You must specify a value for this required field”. Jag börjar titta i webbplatskolumnerna i biblioteket där sidorna sparas och ser inget konstigt, tittar på sidan och det ser också bra ut, jag har ju inte ens ändrat på sidlayouten på dessa sidor utan de använder SharePoints standard för wikisidor.

Söker på internet och hittar några bloggar som skriver om detta och de skriver att man måste lägga till detta

<asp:panel runat="server" Style="display:none;">
<asp:ContentPlaceHolder id="PlaceHolderPageTitleInTitleArea" runat="server" />
</asp:panel>

i den masterpage som används, den som jag faktiskt ändrat lite inför denna lansering. Det jag fick göra var att ersätta testen som stod där:

<h2>
           <asp:ContentPlaceHolder id="PlaceHolderPageTitleInTitleArea" runat="server" Visible="false"/>
</h2>

med tipset ovan så fungerar det alldeles utmärkt att editera och sen spara och stänga wikisidorna. Kunden nöjd och jag har lärt mig något nytt, igen.

Annonser

Kommentera

Fyll i dina uppgifter nedan eller klicka på en ikon för att logga in:

WordPress.com Logo

Du kommenterar med ditt WordPress.com-konto. Logga ut /  Ändra )

Google-foto

Du kommenterar med ditt Google-konto. Logga ut /  Ändra )

Twitter-bild

Du kommenterar med ditt Twitter-konto. Logga ut /  Ändra )

Facebook-foto

Du kommenterar med ditt Facebook-konto. Logga ut /  Ändra )

Ansluter till %s